OptimizePress Minimum Requirements

OptimizePress runs on WordPress which you must be running on your own hosting/server.  You will also need a domain linked to your hosting in order to license your site.

We recommend hosting your site with Hostgator, but if you are using another web host, please check they have the following:

  • Your server/hosting must be running PHP 5.3 or above
  • WordPress 3.21 or above
  • PHP Shortcodes must be enabled
  • cURL must be enabled